.
/
CYBERNET CHASSIS PTMB134AOX
Always check and replace cross connection protection diode
Prestige Models Include
ROTEL RVC240
HARRIER CBX
YORK JCB863
BINATONE 5 STAR
HARVARD 420M
HAM INT. UK
BARACCUDA LJM
SAPPHIRE X-4000
FORD ROADMASTER 505
RADIOMOBILE 202
CYBERNET BETA 3000
FIDELITY 2000
No TX no RX
1/ Try replacing Q16(2SC1318)  or substituted by BC639 (Thanks Niall)
2/ Sometimes transmits one channel, channel selector appears useless. D2 (6.2 Zener Diode) also check PLL IC LC7136/7 by replacement

NO TX
1/ Check if there is any TX at all by checking with a rig on the same channel next to the radio in question. If theres nothing try Q2 (JC502) located behind the
VCO.
2/ Check red trimmer by slight adjustment (TX Shift on the diagram below) as this sometimes gets wax damage and may need cleaning / replacing (very
common) Can also drop channels at their extremes if adjusted wrong. A quick squirt of switch cleaner helps.

No TX power but RX on another Rig
1/
Try replacing O/P transistor (2SC2078) located in the screened area.
2/ Driver Transistor Q5
3/ Red trimmer (again) slight adjustment. Heat with soldering iron then spray with switch cleaner to remove wax.
4/ Check associated coils and track T2, T3, T4 with slight adjustment
5/ Check hi/lo pwr switch and RV5

Problems with Receive

With incoming signal but no sound
1/
Check internal speaker and speaker jack socket (extension speaker)
2/ Check associated wires and track
3/ Replace audio IC (TA7205) which also sometimes affects outgoing modulation too. NB. If you rub your finger across the back of the Audio IC with the
volume up and it makes a sound chances are the IC is fine and the fault lies elsewhere. If its completely dead its more than likely the Audio IC.
4/ Slight adjustment of T12 (Front right) this also if the receive is fuzzy or sounds off frequency.

With very low TX
1/
Try adjusting coils T11, T10, T9, T8, T7, T5 slightly while monitoring signal strength on a nearby rig until the power increases enough to show on the TX
meter or swr/power meter.
2/ Check solder link trackside of T7 (If removed will cause signal drop when RF gain fully open)

Miscellanious Faults

1/ Channels all mixed up, sometimes giving 2 lots of 20 channels,. Where the channel selector pins enter the main PCB, link wires directly from pins to the
PLL IC (common fault where channel selector retaining nut works loose) also check for solder splashes on channel selector board or PLL itself.
2/ Increase TX modulation by linking out R72 or reducing its value and tuning RV2 to suit.
3/ Increase incoming audio by linking out R57 or reducing its value.
4/ VCO is compatible with that from an Amstrad board.
5/ No squelch but associated parts seem ok. Replace audio IC (TA7205).
6/ Low audio/poor sensitivity on RX/low power on TX, replace Q18.
7/ If midblocking, broadband VCO by replacing C4 (33pf to 22pf)
8/ No channel display, replace Q251 on underside of channel selector PCB.
9/ Bad buzz when switched on. FM IF detector faulty (Probably mains or 24v damage)
10/ Feedback on internal speaker on TX, check the Ext. Spr socket still has its insulating washer on.

How to fit a Mid Block        How to wire an RF or MIC Gain to Smaller radio's

Channel 9 Switch to 19 conversion
CB Radio History from its early days
CB Radio Repairers in the UK
Back to top of page
.